Activemq can't run due to - Address already in use: JVM_Bind

+1 vote
asked Jan 15, 2016 by Hitesh Garg (799 points)  

I am currently using activemq for a project and whenever I run it on my local system it logs the following error message.
I have tried to find the process running on this port but nothing shows up for this port.

Caused by: Failed to bind to server socket: tcp:// due to: Address already in use: JVM_Bind
at org.apache.activemq.util.IOExceptionSupport.create(
at org.apache.activemq.transport.tcp.TcpTransportServer.bind(
at org.apache.activemq.transport.tcp.TcpTransportFactory.doBind(
at org.apache.activemq.transport.TransportFactory.bind(
... 41 more

Caused by: Address already in use: JVM_Bind
at Method)
at org.apache.activemq.transport.tcp.TcpTransportServer.bind(
... 47 more

It sometimes work if I restart my system and run activemq as the first thing after restart.

1 Answer

0 votes
answered Jan 16, 2016 by Rahul Singh (682 points)  

I ran through the same issue and I found that I was sharing Internet Connection between LAN and Hotspot. So to solve this follow the steps below -

Solution 1 - Most possible solution

Go to Control Panel -- > View Network Connections --> Right click on your connected network and click on properties.
A new pop up window appears. in that window select sharing tab and disable network sharing.

This will release the port and you can start your activemq after that.

Solution 2

In case solution 1 does not work then-
Open Command Prompt and run netstat -a -o -n.

  • Find the process which is running against the port 61616.
  • Now kill the process from Task maager.